user32.getwindowdc.open('User/u_login.aspx')后如何加数据

Excuse me,what's the EngIish for &xiang pi&的答案是啥?_百度知道
Excuse me,what's the EngIish for &xiang pi&的答案是啥?
提问者采纳
Eraser橡皮如有问题,欢迎继续追问:)求采纳~
提问者评价
你真棒,学习了
其他类似问题
amp的相关知识
等待您来回答
下载知道APP
随时随地咨询
出门在外也不愁Boring String ProblemTime Limit:
MS (Java/Others)&&&&Memory Limit:
K (Java/Others)Total Submission(s): 219&&&&Accepted Submission(s): 45Problem DescriptionIn this problem, you are given a string s and q queries.For each query, you should answer that when all distinct substrings of string s were sorted lexicographically, which one is the k-th smallest.A substring si...j of the string s = a1a2 ...an(1 ≤ i ≤ j ≤ n) is the string aiai+1 ...aj. Two substrings sx...y and sz...w are cosidered to be distinct if sx...y ≠ Sz...w&InputThe input consists of multiple test cases.Please process till EOF.Each test case begins with a line containing a string s(|s| ≤ 105) with only lowercase letters.Next line contains a postive integer q(1 ≤ q ≤ 105), the number of questions.q queries are given in the next q lines. Every line contains an integer v. You should calculate the k by k = (l⊕r⊕v)+1(l, r is the output of previous question, at the beginning of each case l = r = 0, 0 & k & 263, “⊕” denotes exclusive or)&OutputFor each test case, output consists of q lines, the i-th line contains two integers l, r which is the answer to the i-th query. (The answer l,r satisfies that sl...r is the k-th smallest and if there are several l,r available, ouput l,r which with the smallest l. If there is no l,r satisfied, output “0 0”. Note that s1...n is the whole string)&Sample Inputaaa40235&Sample Output1 11 31 20 0&Source2014 ACM/ICPC Asia Regional Xi'an Online&Recommendhujie&&&|&&&We have carefully selected several similar problems for you:&&15&&&题意:给你一个长度不超过1e5的字符串。把它的所有子串去重后排序。然后要你输出第k大的字符串的位置l,r。如果有多个位置输出l最小的。思路:比赛时看到这题感觉和SPOJ-7258&Lexicographical Substring Search很像。不过那是学后缀自动机时看到了。由于后缀自动机是在是不是很好懂。。。所以最后还是放弃了。但是网上有这题的题解。但是很那题有点差别的是这题要求输出字符串的位置。于是就不知道怎么搞了。于是就用相对熟悉的后缀数组想了下。毕竟这题感觉n*log(n)是可过的。然后就开干了。我们先算出来每个后缀sa[i]比sa[i-1]多出多少个不同的子串。明显为len-sa[i]-height[i]存到val[i]。而sa[i]就对应len-sa[i]-height[i]个子串了。然后用val[i]构造线段树。然后找排名第k的字符串怎么找呢。就类似二分的思想了。如果线段树左子树字符大于等于k个就到左子树。不行就到右子树找。这样就可以找到第k大串对应的sa[i]和第k串的长度len。写完这里就卡了下。因为怎么处理l最小的问题呢。不可能在i附近找和sa[i]lcp&=len且sa[i]最小的吧。想了下最发杂的就是全a的情况。这样就退化成O(n^2)了。那sa就白写了。冷静了下。一想。就出来了。我们可以二分求出最左边和sa[i]lcp&=len的位置left。在二分出sa[i]最右边lcp&=len的位置right。然后答案就是left-&right中sa最小的。这个可以用rmq维护。然后接1A了。不过有人就是按我先前的前后直接找的。居然过了。可见数据还是蛮水的。详细见代码:#include&algorithm&#include&iostream&#include&string.h&#include&stdio.h&const int INF=0x3f3f3f3f;const int maxn=100010;#define lson L,mid,ls#define rson mid+1,R,rschar txt[maxn];int sa[maxn],T1[maxn],T2[maxn],ct[maxn],he[maxn],rk[maxn],n,m,le,int rmq[25][maxn],lg[maxn],id[25][maxn],pos,ll num[maxn&&2];void build(int L,int R,int rt){
num[rt]=n-sa[L]-he[L];
int ls=rt&&1,rs=ls|1,mid=(L+R)&&1;
build(lson);
build(rson);
num[rt]=num[ls]+num[rs];}void getsa(char *st){
int i,k,p,*x=T1,*y=T2;
for(i=0; i&m; i++) ct[i]=0;
for(i=0; i&n; i++) ct[x[i]=st[i]]++;
for(i=1; i&m; i++) ct[i]+=ct[i-1];
for(i=n-1; i&=0; i--)
sa[--ct[x[i]]]=i;
for(k=1,p=1; p&n; k&&=1,m=p)
for(p=0,i=n-k; i&n; i++) y[p++]=i;
for(i=0; i&n; i++) if(sa[i]&=k) y[p++]=sa[i]-k;
for(i=0; i&m; i++) ct[i]=0;
for(i=0; i&n; i++) ct[x[y[i]]]++;
for(i=1; i&m; i++) ct[i]+=ct[i-1];
for(i=n-1; i&=0; i--) sa[--ct[x[y[i]]]]=y[i];
for(swap(x,y),p=1,x[sa[0]]=0,i=1; i&n; i++)
x[sa[i]]=y[sa[i-1]]==y[sa[i]]&&y[sa[i-1]+k]==y[sa[i]+k]?p-1:p++;
}}void gethe(char *st){
int i,j,k=0;
for(i=0;i&n;i++) rk[sa[i]]=i;
for(i=0;i&n-1;i++)
if(k) k--;
j=sa[rk[i]-1];
while(st[i+k]==st[j+k]) k++;
he[rk[i]]=k;
}}void rmq_init(){
for(i=0;i&n;i++)
rmq[0][i]=he[i];
id[0][i]=sa[i];
for(i=1;i&=lg[n];i++)
for(j=0;j+(1&&i)-1&n;j++)
rmq[i][j]=min(rmq[i-1][j],rmq[i-1][j+(1&&(i-1))]);
id[i][j]=min(id[i-1][j],id[i-1][j+(1&&(i-1))]);
}}int rmq_min(int l,int r){
int tmp=lg[r-l+1];
return min(rmq[tmp][l],rmq[tmp][r-(1&&tmp)+1]);}int rmq_id(int l,int r){
int tmp=lg[r-l+1];
return min(id[tmp][l],id[tmp][r-(1&&tmp)+1]);}void prermq(){
for(i=1;i&i++)
lg[i]=lg[i&&1]+1;}void qu(int L,int R,int rt,ll k){
if(k&num[rt])
len=he[L]+k;
int ls=rt&&1,rs=ls|1,mid=(L+R)&&1;
if(num[ls]&=k)
qu(lson,k);
qu(rson,k-num[ls]);}int binl(int x){
int low=1,hi=x-1,mid,ans=x;
while(low&=hi)
mid=(low+hi)&&1;
if(rmq_min(mid+1,x)&=len)
ans=mid,hi=mid-1;
low=mid+1;
}}int binr(int x){
int low=x+1,hi=n,mid,ans=x;
while(low&=hi)
mid=(low+hi)&&1;
if(rmq_min(x+1,mid)&=len)
ans=mid,low=mid+1;
}}inline ll ReadInt(){
char ch = getchar();
if (ch==EOF) return -1;
ll data = 0;
while (ch & '0' || ch & '9')
ch = getchar();
if (ch==EOF) return -1;
data = data*10 + ch-'0';
ch = getchar();
} while (ch &= '0' && ch &= '9');}inline void putit(int x){
if (x/10&0) putit(x/10);
putchar(x%10+'0');}int main(){
int q,lll,
while(~scanf(&%s&,txt))
m=150,n=strlen(txt);
getsa(txt);
gethe(txt);
rmq_init();
build(1,n,1);
scanf(&%d&,&q);
while(q--)
kth=ReadInt();
kth=(le^ri^kth)+1;
qu(1,n,1,kth);
if(pos==-1)
putit(le),putchar(' '),putit(ri),putchar('/n');
lll=binl(pos);
rrr=binr(pos);
le=rmq_id(lll,rrr)+1;
ri=le+len-1;
putit(le),putchar(' '),putit(ri),putchar('/n');
return 0;}
无相关信息同类热门资料
资料下载地址
(确认已经开启迅雷或电驴)
受版权保护
原着:J.K.Rowling
朗读:Stephen Fry
申明:已通过安全检测
杀毒软件:Symantec AntiVirus 10.0.2.2000
病毒库:日
服务器:R2(最近好像又能连上了)
开机时间:早上10:00至晚24:00
最大上传速度:50k/s (幸亏不是首发)
由于本人带宽有限,且是转发,大多数源都在国外,故下载速度可能比较慢。
原来下载并听得是论坛里其他人发的mp3格式的,这几本书是几个月通过emule搜索下载的,当时的源基本全都是国外的,下载后本人只听了第5部,其余四部还没有听,发出来给方便iPod的用户
解压后前四部不是按章节独立而是被分为4(第二部)或5部分(第一、二、四部),只有第五部是按章节独立分割
此版本为英国版而不是美国版,朗读者Stephen Fry朗读,口语为英国英语(British English),m4b格式,须传输至iPod播放。
文件格式为m4b,一般的MP3不能兼容播放,只有苹果公司的iPod系列(如果其他品牌的MP3可以的话告诉兄弟一声)才可正常播放,或者安装相关解码器(好像是)在电脑上播放。
如不是iPod用户或者十分想收藏这个格式在电脑里听得的朋友,请选择论坛里mp3格式,以免劳而无功
用iTunes 6.0.2.23播放第五部的第一章时候显示的文件简介,主要内容如下:
种类:被保护的AAC音频文件 描述文件:低复杂性
位速率:64kbps 声道:立体声
采样速率:44.100kHz 编码方式:iTunes v4.8.0.32,QuickTime 6.5.2
另,我在emule里没搜到第六部m4b(不是mp4)格式的,如果有人发现,请pm我一下,谢谢
下面的Harry Potter and the Half-Blood Prince也是我通过emule搜索后花了一段时间从国外的源下来的,如果有需要可以考虑。论坛里也有其它版本和格式的(如美版是美音、Jim Dalel朗读,有mp3和mp4格式,及不同编码大小),请根据不同需要选择
用相关的关键词(如m4b)在emule里可以搜索到更多给iPod用户的audiobook等(如达芬奇密码等),大家搜索到自己有兴趣的下载后别忘了发上来,也可以搞成类似HDVD似的分类,让广大iPod用户拽一拽(本人比较懒)
摘录是网友googoofox关于m4b的回复,供大家参考(文中mb4怀疑为m4b的笔误,shuffle等部分俺也没完全明白)
是mb4不是mp4。两个风马牛不相及的。
mb4里面的b是bookmark的意思
是itunes里面aac格式的升级版。就是说你将mp3转为aac后,再改动一下,pc下面改后缀名(大家都知道的),再倒入itunes,就会发现能变速播放(真正学英语的才不会用这个功能呢),有书签记忆功能。shuffle音乐的时候会自动屏蔽主要是针对audiobook的。apple下面转换更方便。
但是,在itunes里面就是不用转aac,普通的mp3也有选项,达到同样功能。所以转不转无所谓,唯一的区别,就是在browser里面能将music和audiobook栏目分开,不至于都显示到music栏目下面。
不过对我来说也意义不大,因为我喜欢点all栏,然后按照genres排,这样声音文档和文本都可以在一个专辑下面(估计没多少人知道itunes也支持pdf)
ps,对于aac格式,包括其升级版的audiobook,podcast(这两个根本就是孪生兄弟)有限制的。
做文件不要超过5个小时的内容。300M?(我记不清了),因为转换时会临时解压,超过这个容量就会出现错误,严重的是会丢声音片断的。
另外比较欣赏的mb4的特点是加chapter,曾经非常着迷做这个,不过现在激情消退了。用apple电脑的话,很方便,狂多软件支持,主要是因为用到apple提供的一个分章节的工具(说白了,还是作chapter标记,转aac),pc下面没有,因为苹果不提供windows平台的。但国外有牛人编程序,不过你要银子买的。
但是,现在懒得分章节了,一本书反正也有书签,觉得章节用处也不大了。再说很多mp3没分章节,我还得听后,在pdf对照分章节。分完后也不想看了。
写出来只是想普及普及大家。itunes不错,管理性是最好的,属于动态分类,很科学。
而且楼主很好心细心的写出注意的地方,我也想帮忙。(另外也是因为楼主的大名,厚厚)如果觉得有用,不妨在一楼补贴上,让大家都看看。
如果标题能改为itunes专用,就更确切了。(我记得foobar,winamp好像也有插件的)这样不会吓退很多人。
我自己是把harry potter所有有声都做成chapter的了,(因为当时很闲)。只是因为我最后都转换为低音质的,(反正是阅读,声音够清晰,还小),所以这里就纯支持了。
如果大家还有问题,也愿意解答哟。:)
相关学习资料
&&&& &&&&&&&&&&&&&&&&
学习资料库,由广大资源爱好者通过共享互助而共享各种学习资料,但学习资料库无法保证所共享资料的完整性和合理性
版权所有 Gzip enabled$(&input[name='grpid']&).each怎么解释_百度知道
$(&input[name='grpid']&).each怎么解释
我有更好的答案
按默认排序
乱码额。。。
其他类似问题
等待您来回答
下载知道APP
随时随地咨询
出门在外也不愁}

我要回帖

更多关于 user login 的文章

更多推荐

版权声明:文章内容来源于网络,版权归原作者所有,如有侵权请点击这里与我们联系,我们将及时删除。

点击添加站长微信